Download the 3Dfx-Only Demo Here.

This demo requires that you have DirectX 5
or higher
and Glide 2.43 or higher in order
to run correctly on your computer.

 


 

Imagemap - Load!

[ Previous | List Sites | Random Site | Next 5 Sites | Next ]